В11

Материал из Saratov FIO Wiki
Перейти к: навигация, поиск

Сделала Евдокимова Т.Ю.

Правило форматирования последовательности на ШАЯ:'

алг последоваетльность (арг цел А, В, с)

нач цел К

если В> то

нц для К от 0 до 3

вывод С, ","

С:=С*А+В

кц

все

кон

Пропущенный член последовательности: ..., -5,23,-89; равен _______

Решение:

Изходя из условий, начальное значение С не известно, а второй член С=-5.

Значения А и В и искомое значение можно получить, построив систему уравнений

на основании оператора присваивания и значений С, введенных при К=1, К=2 и К=3.


Form1.JPG


В= 23 + 5*А

В= -89 - 23*А


23+5*А= -89-23*А

5*А+23*А= -89-23*А

28*А= -112

А= -112/28=-4, А= -4


В= 23+5*(-4)= 23-20= 3, В=3.

С=(-5-В)/А С=(-5-3)/(-4)=-8/(-4)=2, С=2.


Решая систему уравнений получила: А=-4, В=3, С=2.


Сделаю проверку: С(1)=2 при К=0;

К= 1 С=2; С=2*(-4)+3=-8+3= 5.

К= 2 С=5; С=-5*(-4)+3=20+3= 23.

К= 3 С=23; С=23*(-4)+3=-92+3= -89.

Получила последовательность чисел 2; -5; 23; -89.

Ответ: Пропущенный член последовательности = 2.